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INTRODUCTION 
TO MS EXCEL 2013

ESSENTIAL LEARNING OBJECTIVES
1.1	 STARTING A EXCEL PROGRAM

1.2	 BASIC SPREASDSHEET ELEMENTS

1.3	 NAVIGATING IN A WORKSHEET

1.4	 SAVING A WORKBOOK

1.5	 OPENING A WORKBOOK

1.6	 USING FORMULAS AND FUNCTIONS:

1.7	 COPYING AND PASTING FORMULAS AND FUNCTIONS

1.8	 CELL REFERENCING:

1.9	 WORKING WITH WORKSHEET RANGES

1.10	 WORKING WITH ROWS AND COLUMNS

1.11	 CLEARING DATA

1.12	 SELECTING CELLS

1.13	 EDITING CELL CONTENTS

1.14	 CHANGING ROW HEIGHT

1.15	 CONDITIONAL FORMATTING:

1.16	 TAB COLOURS

1.17	 CHARTS

1.18	 FINDING AND REPLACING DATA

1.19	 AUTOFILL

INTRODUCTION TO MS EXCEL

There are different spreadsheet programs available like Microsoft Excel, Lotus 123, etc. A spreadsheet is defined 

as a large sheet which contains data and information arranged in rows and columns. Data is entered in a cell, 

which represents the intersection of a row and a column. The most powerful feature of a spreadsheet is that it 

automatically recalculates the result of mathematical formulas if the source data changes. A spreadsheet can help us 

quickly record and manipulate a large amount of numerical information and share it with others in a wide variety 

of forms. Spreadsheets, also known as worksheets, allow us to perform detailed analysis on numerical data.
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1.1 STARTING A EXCEL PROGRAM

There are number ways available to start MS Excel. The most common way to start MS Excel is given below:

1.	 Click Start button

2.	 Click All Programs

3.	 Click MS Office

4.	 Click on MS Excel

A Blank spreadsheet as shown in 

this figure is seen here.

1.2.1 1.2 BASIC SPREASDSHEET ELEMENTS

1.2.1	WORKBOOK AND WORKSHEET
Excel spread sheet file is known as a workbook and is has a default extension name  .xlsx. Each workbook can contain 
many sheets, so various kinds of related information can be organised in a single file. Each workbook can contain up 
to 255 worksheets, but by default it displays only three. Worksheet is the area where the data is stored and work is 
performed. Extra worksheets can be added as and when required. A workbook can also have sheets that show charts 
– and these sheets are called chart sheets.

1.2.2	ROWS, COLUMNS AND CELLS
The Excel Worksheet is made up of rows and columns. The horizontal arrangement of cells is called as a row and the 
vertical arrangement of cells is called as a column. The rows in a worksheet are numbered from top to bottom along 
the left side of the worksheet. The columns are labelled from left to right with letters along the top of the worksheet. 
. The total number of rows in Excel are 1048576 and the total number of columns are 16,384. Columns are named 
from A to XFD. The rows are numbered from 1 to 1048576. 
A Cell is the intersection of a row and a column. Every cell is identified by a cell address that consists of the column name 
followed by the row number. For example, the first cell is referred to as A1, which indicates that cell lies at the intersection 
of the column A and row 1. One cell in the worksheet has a dark border around it and is referred to as the active/
selected cell. All the action in the worksheet happens in the active cell. You can click the cell to make it the active 
cell. The active cell is ready for accepting any action or input. A small group of contiguous cells is defined as a range. The 

An excel sheet is quite 
big with 17.2 billion 
cells in it alone!!!
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range is referred to by writing the starting address of the cell in the range: Ending address of the cell in a range or vice 
versa. For example A1:A10 (can also be referred as A10 : A1).
1.3	 NAVIGATION

1.3.1	NAVIGATING IN A WORKSHEET
There are a numbers of ways that you can use to navigate in the worksheet. 1) The cursor keys, 2) mouse and 3) 
the scroll bars can be used to navigate through the worksheet. However, navigating through the 1048576 rows 
and 16,384 rows and columns using these techniques is very inefficient. Shortcut keys are more efficient and can 
be used to move to any cell directly without scrolling through the entire worksheet. Some 

Method 1 : Using key combinations
MOVEMENT KEY STROKE

One cell up Up arrow (↑)

One cell down Up arrow (↓)

One cell left Up arrow (←) or Shift + Tab 
key

One cell right Up arrow (→) or Tab key

Cell A1 Ctrl + Home

End of	 the worksheet	 (last cell 
containing data)

Ctrl + End

End of row Ctrl + right arrow

End of column Ctrl + down arrow

Method 2 : Using the Name Box
1.	 Type the cell address in the Name Box

2.	 Press ENTER to reach the desired cell.

For example, to move to cell D6, enter D6 in the Name Box and press ENTER. The cursor is positioned on the 
cell in the D column and 6th row.

Method 3 : Using the Go To
1.	 Press F5 or CTRL + G or choose Go To option from the Edit menu to  
	 invoke the Go To dialog box.

2.	 Enter the cell coordinates in the Reference textbox.

3.	 Click OK to move to the desired cell.

1.3.2	NAVIGATING BETWEEN WORKSHEETS
To move between worksheets, simply click on the sheet number in the lower left corner of the screen . In case the 
number of worksheets is more than the number which can be displayed use the tab scrolling buttons, located next 
to the sheet numbers and then click on the sheet number to select it.
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The tab scrolling buttons and their use are given below:

ICON MOVEMENT
 To display the last worksheet

 To display the first worksheet

 To display adjacent worksheets on the right

 To display adjacent worksheets on the left

1.4	 SAVING A WORKBOOK
There are a numbers of ways that you can use to save a  workbook. The most common method to save a Workbook 
is given below:
1.	 Click File tab 
2.	 Click Save or Click on the Save button on the Quick access Toolbar or Close the workbook by clicking on the 
Close button. (Follow the steps 3 to 6 if the file is already not saved.)
3.	 Click Browse
4.	 Select the directory in which the file is to be saved.
5.	 Type the name of the file in the File Name text box.
6.	 Click Save.

1.5	 OPENING A WORKBOOK
There are a numbers of ways that you can use to open a  workbook. The most common method to oprn a 
Workbook is given below:

1.	 Click File Tab

2.	 Choose Open option or Click on the Open button on the Quick access Toolbar.

3.	 Click Browse

4.	 Select directory in which the file has been saved.

5.	 Type /Select  the name of the file to open.

1.6	 USING FORMULAS AND FUNCTIONS: 
A formula is an expression that operates on values in a range of of cells. 
Formulas are mathematical equations that perform calculations and 
data analysis on the contents of the cells. Formulas can be as simple 
as adding a column of numbers together or  as complex as a statistical 
graph of a data set. They can be incredibly useful when you want to 
turn spreadsheet data into meaningful information for driving business 
decisions.

The cell will Automatically recalculate the value of 
a formula when cell reference is used in the formula.
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1.6.1	ENTERING FORMULAS:
All formulas in Excel start with the equal sign (=) - and build from there. The formula consists of the coordinates of the cells 
that are used in the formula, operators and functions. Formulas must begin with an = sign, otherwise it is treated as 
a text entry.

1.6.2	USING ARITHMETIC OPERATORS
To add the numbers in two cells together, first click the on the target cell where you want the total to appear. Then 
type = in the cell to start the formula. Next type or click the cell - to refer to the cell containing the number - here it 
is A1, A1 will appear next to the equal sign in the formula. Type + next to the first cell reference- A1. Then click the 
cell that contains the second number you want to add, here it is A2 and its cell reference (such as A2) will appear 
next to the + sign. The full syntax for the formula to add the values in cells A1 and A2 is:
=A1+A2
Note that in addition to appearing in the target cell, the formula also appears in the formula bar directly above the 
worksheet. Once you’ve inserted the initial = sign in the target cell, you can type your formula in the formula bar. It’s 
sometimes easier to see the whole formula and work with it in the formula bar than down in the worksheet page.
If you wanted to add additional numbers to your total, you’d type another + sign, select another cell, and so on. Once 
your formula is complete, press Enter, and the result appears in the target cell.
Subtraction, multiplication, and division calculations work the same way. You simply change the operator — the 
symbol that tells Excel what math operation you want to perform — from the + sign to the – sign for subtraction, 
the * sign for multiplication, or the / sign for division.

1.6.3	  FUNCTIONS
A function is a predefined formula that performs calculations using specific values in a particular order.  
A function will simplify the formulas that you should type in manually. There are a number of functions available in 
Excel. 
The general  form of writing a function
1.	 Use an equal to sign (=) to begin a formula.

2.	 Specify the function name.

3.	 Enclose arguments (data values that is/are calculated by the function) within parentheses.

4.	 Use a comma to separate arguments.

1.6.4  USING AUTO SUM
AutoSum is a feature in Microsoft Excel spreadsheet software that allows you to quickly and automatically calculate 
the sum of a range of numbers. 
To use AutoSum in Microsoft Excel, first select the cell where you want the sum to appear. Then, click on the 
AutoSum button (Σ) located in the Home tab of the ribbon. Excel will automatically detect the range of adjacent 
cells containing numbers and suggest a sum formula. Press Enter to apply the formula and display the calculated 
sum in the selected cell.
AutoSum provides quick access to various other common functions like Average, Count, Max, Min, and more. 
This feature makes it convenient to perform a variety of calculations without having to manually type the formulas.

1.7  COPYING AND PASTING FORMULAS AND FUNCTIONS
After creating a formula in Excel, you can use the Copy and Paste commands to duplicate or transfer the formula 
into other areas of your worksheet. 
When you use cell references in your formulas, Excel uses the data stored in that location in its calculations. The 
benefit is that when you change the original data, the formula is updated as well.  
If you copy a formula from one location to another, Excel adjusts the cell reference based on its new location. For 
instance, the formula =B2*B3 entered in cell B5 would be adjusted to =C2*C3 when copied to cell C5. However, 
you can modify the cell reference so it remains fixed to its original location.
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1.8	 CELL REFERENCING:
Each cell has a unique address, Cell address is also called Cell reference  and it identifies the location of the cell 
in the spreadsheet by using a combination of column name and row number. For example, “A1” refers to the cell 
located at column A and row 1. 
Cell References are crucial, particularly when working with huge data sets in functions and formulas.

1.9	 WORKING WITH WORKSHEET RANGES
Each cell is referred to by a cell address. A range is a block of two or more cells. A group of cells are referenced using the 
range reference operator - :   (the Colon)
A range reference consists of two cell addresses separated by a colon. A range reference refers to all the cells between 
and including the reference. The range reference B1:B4 includes cells B1, B2, B3 and B4. The range reference A1:B3 
includes A1, A2, A3, B1, B2 and B3.

1.10	 WORKING WITH ROWS AND COLUMNS
To add extra information to a worksheet, it may sometimes be desirable to insert new rows and columns. To insert 
a new row/ column, execute the following steps:

1.10.1  INSERTING A ROW
1.	 Click on the Row header (or any cell in that row) above which the new row is to be added.
2.	 Choose the Insert>Insert Sheet Rows in the Home tab. A new row is added above the selected row (or right 
click any cell in the row and choose insert > entire row)

1.10.2  INSERTING A COLUMN
1.	 Click on the Column header (or any cell in that column) to the left of which the new column is to be added.

2.	 Choose the Insert>Insert Sheet Column in the Home tab. A new column is added to the left of the selected 
column (or right click any cell in the column and choose insert > entire column)

1.10.3  DELETING ROWS AND COLUMNS
1.	 Click on the Row header/Column header to be deleted.

2.	 Choose the Delete option from the Home tab or right click and select Delete sheet column/row option from 
the pop-up menus.

1.10.4  INSERTING AND DELETING CELLS
a.	 Inserting a Cell

1.	 Click on the cell where new cell(s) is to be inserted.

2.	 Choose the Insert Cells option from the Home tab. The Insert dialog box is 
displayed (Figure →)

3.	 Choose the appropriate option. The result of each option is explained as under:

(a)	 Shift cells right – adds a blank cell to the left of the selected cell.

(b)	 Shift cells down – adds a blank cell above the selected cell.

(c)	 Entire row – adds a new row above the selected cell.

(d)	 Entire column – adds a new column to the left of the selected cell.

(e)	 Click on OK button.
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b.	 Deleting a Cell

1.	 Click on the cell which is to be deleted.

2.	 Click the Delete> Delete Cells option from the Home Tab. The Delete dialog 
box is displayed as shown in figure.

3.	 Choose the appropriate option. The result of each option is explained as under:

(a)	 Shift cells left – the cells to the right of the deleted cell are moved left.

(b)	 Shift cells up – the cells below the deleted cell are moved up.

(c)	 Entire row – deletes the entire row and moves the row below upwards.

(d)	 Entire column – deletes the entire column and moves the row to the right 
leftwards.

4.	 Click on OK button.

1.11	 CLEARING DATA
There are a number of  options to clear the content from a cell: 
1. Press Delete on the keyboard. 
2. Right-click the cell and then select Clear Contents. 
3. On the Home tab, in the Editing group, select Clear > Clear Contents. 
Unfortunately, clearing a cell’s content doesn’t clear its formatting. To clear formatting:  
On the Home tab, in the Editing group,  select Clear > Clear Formats  
To clear both contents and formats at once, select Clear All.
In contrast, deleting the cell removes the cell itself from the stack and makes the 
surrounding cells shift. Think about what happens when you pull a box out of a stack 
of boxes-the boxes above it fall down one position, right? It’s the same thing with 
Excel cells, except it’s reverse-gravity (cells fall up rather than down), and you have 
the choice of making the remaining cells shift up or to the left.
Choose the relevant option from the Clear sub-menu. The Clear sub-menu offers four choices. 

1.12	 SELECTING CELLS
To perform a function on any particular cell or a group of cells, the cell or cells need to be first selected. Selecting a single 
cell is as simple as clicking on it.
a.	 SELECT A ROW
To select an entire row, click on the row number to be selected on the left side of the spreadsheet. 
b.	 SELECT A COLUMN
To select an entire column, click on the column label at the top of the spreadsheet.
c.	 SELECT ALL CELLS IN A WORKSHEET
Click on the empty grey box in the left corner between A and 1. This area is called the Select All button.

1.13	 EDITING CELL CONTENTS
Once you’ve entered data into cells, select the area you want to edit by highlighting it. 
Method 1 : Using the F2 Key
1.	 Move the cursor to the desired cell whose contents have to be edited.
2.	 Press F2. Make the necessary changes.
3.	 Press Enter.
Method 2 : Using the Formula Bar
1.	 Move the cursor to the desired cell whose contents have to be edited.
2.	 Click in the formula area of the Formula Bar.

3.	 Make the necessary changes.

4.	 Press Enter.
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Method 3 : Double-click in the Cell

1.	 Move the cursor to the desired cell whose contents have to be edited.

2.	 Double-click in the cell.

3.	 Make the necessary changes.

4.	 Press Enter.

1.14	 CHANGING ROW HEIGHT
There are two methods to change the row height.
Method 1 : Using the Home Tab
1.	 Place the cursor anywhere in any cell of the row whose height is to be changed.
2.	 Choose the Format > Row Height in Cells group, of the Home tab. A dialog box opens.
3.	 Type in the required Row Height in the dialog box and click on OK.
Method 2 : By Dragging
1.	 Place the cursor on the line between the 1 and 2 row headings. The cursor should look like the one displayed 
above, with two arrows.
2.	 Move the mouse downwards or upwards while holding down the left mouse button. The height indicator 
appears on the screen.
3.	 Release the left mouse button when the height indicator shows the desired height.

1.15	 CONDITIONAL FORMATTING:
This feature allows the user to apply formats to cells that satisfy a predefined criterion. To apply conditional 
formatting, perform the following steps:

1.	 Choose Conditional Formatting option from the Format menu.

2.	 In the Conditional Formatting dialog box (Figure 4.19) specify criteria using the various options.

3.	 Click Format.

4.	 Select the font styles, borders, shading and other options to be applied.

5.	 Click OK to apply the formats to cells that meet the specified criterion.

1.16	 TAB COLOURS
To separate out worksheets from one another, it is possible to give different colours to the name of the worksheets 
at the bottom left corner. The steps to be followed for achieving this are

1.	 Click on the Sheet name.

2.	 Right click and in the pop up box choose the Tab Color option.

3.	 Select the desired colour from the Format Tab Color Dialog Box

4.	 Click on OK to see the effect.

1.17	 CHARTS
A chart is a graphical representation of data. Graphics are easier to understand than boring numbers and texts, so 
Charts are valuable tools for Data Visualisation. Charts represent data graphically, making it easier for anyone to 
interpret it within seconds. Various Chart in Excel, such as List of Column Chart, Bar Chart, Area Chart, Line Chart, 
Surface Chart, Scatter Chart, Pie Chart, Stock Chart, Bubble Chart, and Radar Chart helps in communicating 
valuable insights when there are large volumes of data.

1.18	 FINDING AND REPLACING DATA
Use the Find and Replace features in Excel to search for something in your workbook, such as a particular number 
or text string. You can either locate the search item for reference, or you can replace it with something else.  
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 The shortcut keys to open the Find dialog box is Ctrl + F and keys used to replace the text  is Ctrl + H.

1.19	AUTOFILL

Excel contains a feature called AutoFill, which copies a logical series of values, labels or formulas. The AutoFill 
handle, which is like the “+” mathematical operator, can be located at the bottom right corner of the active cell.

To fill series perform the following steps:

1.	 Click on the first cell and type in “01-May”.

2.	 Click on the cell again and then position the mouse in the bottom right of the cell so that the cursor turns to 
a small black plus sign, as shown below.

3.	 With the cursor, click, hold and drag the mouse down.

4.	 It automatically copies the date and increments by one day for each cell going down, giving the series 1-May, 
2-May, ... , 10-May. It keeps showing exactly which day is being filled. Release the mouse when the desired date is 
reached.

DO IT YOURSELF ACTIVITY 
ACTIVITY : - CREATING THE MARK SHEET TABLE

Step 1: To Create a MarkSheet Table with the following fields – Sno., Name, Eng, Lang, Maths, Sci, Soc. Enter 10 
records for the given table.

Step 2: To add the following fields to the table – Total, Average, And update these new fields using appropriate 
formulae. ( Use the SUM() and AVERAGE() functions)

Step 3: Also generate the subject totals and averages, and the Max and Min marks obtained in each subject.

Step 4 : Format the column headings. Also merge and center the Table headings between the Columns A and 
Column G.

Step 5: Use Conditional Formatting and show marks that are less than 40 in red colour and 100 marks in green 
colour.

Step 6 : Apply grid lines for the tabular data of the table.

ACTIVITY 2 :
CREATE A CHART
Type the data for the given table from cell A1 to cell F6. 
Generate the total population using the sum() function in 
the cellsB7 to F7.

Format the table as shown in the picture.

Select the data from A3 to F6 and click Insert Tab Chart 
Column ChartsStacked Column chart type under 
Illustrations.

ACTIVITY 3:
Prepare an analytical result report of Second Monday Test Round Exam of your class in the format 
given below

Instructions :

•	 Calculate the total marks obtained by each student in column I.

•	 Calculate the highest and lowest marks obtained in each subject in row 9 and 10 respectively.
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•	 Also calculate the aggregate/percentage 
marks obtained by each student in column J 
(Insert a column after column I)

•	 Give the number of students appearing for 
each subject in cell B8.

•	 Find the subject-wise average marks and 
display them cells from c8 to H8.

ACTIVITY 4:

Prepare a score sheet of an inter-house cricket match in your school:

A B C D E F
Batsman Balls Faced Fours Sixes Singles Total

Gurman Singh 61 7 3 23
Harinder Singh 12 2 4 2

Sachin
Gupta 132 21 10 64

Gourav Sachdev 17 4 5 7
Ishwaq Ahmed 23 3 3 6

Instructions

1.	 Calculate the total runs obtained by each student in column E. ( Total = No. of sixes x 6 + No. of fours x 4 + 
No. of Singles)

2.	 Calculate the Strike Rate of each batsman in column F.

3.	 Draw the pie chart to compare the strike rate of each batsman.

ACTIVITY 5:

Prepare a personal expenditure report of last financial year in the format as below.

A B C D E F G H I
Pocket -Money Expenditure Report 2008-09

SNO MONTH MOBILE TRAVEL HOBBY DINNER 
DATES

SAVINGS TOT

1 APRIL 1200 900 500 1000
2 MAY 1440 788 700 1500
3 JUNE 1320 1110 700 1200

Instructions

•	 Assume that you are given a monthly pocket-money of Rs. 6000.

•	 Calculate the savings made by you every month.

•	 Calculate the total expenditure in each month.

•	 Calculate the highest and lowest expenditure made.

•	 Calculate the total savings after the three months

•	 Draw the bar graph to compare the expenditure of various months
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BR AIN DEVELOPER

I. CHOOSE THE CORRECT ANSWERS:
1. The name box

	 a. 	 Shows the location of the previously active cell	 b. 	 Appears to the left of the formula bar

	 c. 	 Appears below the status bar	 d. 	 Appears below the menu bar

2.  An excel workbook is a collection of

	 a. 	 Workbooks	 b. 	 Worksheets

	 c. 	 Charts	 d. 	 Worksheets and charts

3. 	Excel 2013 files have a default extension of

	 a. 	 Xls	 b. 	 Xlsx

	 c. 	 Both a. and b.	 d. 	 123

4. 	Without using the mouse or the arrow keys, what is the fastest way of getting to cell A1 in a spreadsheet?

	 a. 	 Press Ctrl +Home	 b. 	 Press Home

	 c. 	 Press Shift + Home	 d. 	 Press Alt + Home

5. Which of the following methods cannot be used to edit the contents of a cell?

	 a. 	 Press the Alt key	 b. 	 Clicking the formula bar

	 c. 	 Pressing the F2 key	 d. 	 Double clicking the cell

6. To copy cell contents using drag and drop press the

	 a. End key 	 b. 	Shift key       	 c. 	 Ctrl key	 d. 	 Esc key

7. Where does the active cell’s contents display in Excel?

	 a.	 Name Box	 b. Row Headings	 c.	 Formula Bar	 d. Task Pane

8. A range refers to a

	 a.	 Row				        b.     Column

	 c.	 a rectangular selection of cells		      d.     Group of non-contiguous cells

9.	 What type of cell referencing does not change while copying formulas.

	 a.	 Relative referencing	 b.	 Mixed referencing

	 c.	 Absolute referencing	 d.	 None of the above

10.	 Which of the following function keys is used as a toggle key for changing referencing modes?

	 a.	 F2	 b.	 F8

	 c.	 F4	 d.	 F6

Teacher’s Signature
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ESSENTIAL LEARNING SKILLS :
2.1	Cell References in Excel

2.2	Cell Reference in a Function

2.3	Types of Cell References in Excel

2.4	Switching between Different Reference Types

2.5	Cross Reference in Excel Do It Yourself Activities Answer the following

2.1	 CELL REFERENCES IN EXCEL
Excel workbook is made up of worksheets and chart sheets.. Each worksheet in Excel consists of several cells formed 
by rows and columns. Each cell has a specific reference (or cell address) which helps the users easily access/address 
the desired cell (s) from within the functions. Cell references play an important role in Excel, especially when using 
functions and formulas with large data sets.

2.1.1 What is a cell reference?

What is a cell reference in Excel?

A cell reference or cell address is a combination of a column letter and a row number 
that identifies a cell on a worksheet.

For example, A1 refers to the cell at the intersection of column A and row 1; B2 refers 
to the second cell in column B, and so on.

Cell reference mainly helps the Excel program locate the cell within the sheet and 
read or use its data in the specified formula to generate the result. We can use cell references or a range of multiple 
cells in other cells when creating a formula, even if the corresponding cell is on the same sheet, different sheet, or 
different workbook.

2.1.2 Relative Reference

The basic use of a cell reference can be displayed by simply mentioning the 
referred cell with the equal sign. For example, if we enter “=A1” without 
quotes in another cell within the sheet, the value of A1 will be displayed in 
the corresponding cell. This means that the value of the selected cell, where 
the cell reference is entered, is exactly equal to that of cell A1.

2.1.3 Reference to a Cell Range

We can also use the reference of multiple cells at once by referring to their cell range. For example, if we use the 
notation “=A2:C6” without the quotes, we refer to the entire cell range from A2 to C6. However, a range alone is 
not valuable data in Excel. When we use this cell reference in an Excel cell, Excel gives the #VALUE! error, which 
means that the formula is missing. Therefore, a reference to a cell range (A2:C6) has meaning only when used 
within a function or formula.

USING  ABS OLUTE AND RELATIVE 
REFERENCES IN EXCEL  

F ORMULAS

CH
AP
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2.2	 CELL REFERENCE IN A FUNCTION
Excel has a wide range of built-in functions that can be used with cell references 
in formulas. These functions perform specific calculations or operations, and 
they can greatly enhance the power and flexibility of your Excel formulas.

For example, the SUM function adds 
up the values in a range of cells, the 
AVERAGE function calculates the 
average of a range of cells, and the 
COUNT function counts the number of 
cells in a range that contain numbers. These functions can be used with any 
type of cell reference, depending on your needs.

2.3	 TYPES OF CELL REFERENCES IN EXCEL
References in Excel are a fundamental part of the spreadsheet. They refer to each cell of a workbook and thus access 
the value contained in them. Cell references in Excel are a widely used resource when performing mathematical 
operations. 
The two main types of cell references: relative and absolute. Each one has a specific purpose, and knowing how to 
use each type is key to creating accurate formulas and working with data.
	 Relative Cell Reference
	 Absolute Cell Reference

2.3.1 Relative Cell Reference
A relative cell reference is a reference to a cell that is relative to the position of the formula. Relative references are 
useful when you want to copy a formula to a range of cells. The reference will change when you copy the formula, 
so that it always refers to the correct cells. For example, if you have a formula in cell A1 that sums the values in cells 
A2:A5, the references in the formula will change when you copy the formula to cell B1. The new formula will sum 
the values in cells B2:B5.
To create a relative reference, simply enter the cell address without using dollar signs ($). For example, if you want 
to reference cell A1, you would just enter A1 (without the $ sign).
When we copy formulas from one relative cell to others, the cell references are automatically adjusted by Excel based 
on respective rows and columns. The relative cell references are commonly used to perform the same operation on 
multiple relative cells by changing the corresponding cell’s column and row addresses in the formula.
Example-  we have the following Excel sheet with numbers in columns A and B, and we want to show the sum 
of the values in column C.

Select cell C2 to enter the formula “=A2 
+ B2” without quotes. and press the Enter 
key to get the calculated value in the cell C2.
Now let’s copy-paste fo rmula  in  cell 
C2 to the cells C3 to C8, Alternately, we 
can click and drag the fill handle (at the 
bottom-right corner of the active cell C2) 
from cell C2 to C8.

After copying the formula to all corresponding cells from C2 to C8, check the addition formulas in the cells C3 to 
C8. For instance, if we select cell C5, we can see that the addition is performed between cells A5 and B5.
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It is clear that the relative address of cell A2 changes to A5 and B2 to B5. Similarly, the 
relative addresses of other cells also change accordingly based on the relative position of 
the respective row and column.
To create a relative reference, simply enter the cell address without using dollar signs ($). 
For example, if you want to reference cell A1, you would just enter A1.

2.3.2 Absolute Cell Reference
An absolute cell reference, on the other hand, does not change when copied and pasted. It always refers to the same 
cell, regardless of where the formula is located. An absolute cell reference is indicated by a dollar sign ($) before the 
column letter and row number. For example, $A$1 is an absolute reference to cell A1.
This type of cell reference is useful when you have a constant value in a formula. For example, if you have a tax rate 
in cell A1 and you want to apply it to a range of income values in column B, you would use an absolute reference 
to cell A1 in your formula.

Using Absolute Cell References in Excel?
Suppose, we have the following Excel sheet with some items (Column A) with their initial prices (Column B). However, 
the prices have increased by 5% (cell E2), and we need to calculate the new price for each item using the absolute cell 
reference.

Perform the following steps using  absolute reference to calculate increased prices (Column C) for each item:

1.	 Select the destination cell and enter the formula to 
calculate the new/increased price. In our case, we select 
cell C2 and enter the formula “=B2*$E$2+B2” 
without quotes and press the Enter key to get the new 
increased price in cell C2.

	• According to the formula above, we multiply 
the item’s initial price with the increased percentage 
rate and add the resultant value to the old price for the respective item. In this way, we can calculate the increased 
price of the item.

	• Since the increased rate percentage is fixed (5%) 
for each item, we add the dollar ($) signs with E2 cell 
to make it absolute, i.e., $E$2. Thus, $E$2 will be 
unchanged after copying the formula into other cells.

Next  we must copy-paste cell C2 to other relative cells 
from C3 to C8. Alternately, we can click and hold the 
fill handle from the bottom-right corner of cell C2. We must drag the fill handle to the last cell we want to copy the 
respective formula. In our case, we drag the fill handle to cell C8.

	• When copied the formula into other relative cells, the 
values from column B change automatically. However, the 
absolute reference ($E$2) does not change. For instance, 
if we select cell C5, we can see that cell B2 has changed to 

B5, but $E$2 
is constant.

Note that we must use the dollar ($) sign in both row and column letters 
of cell reference to create an Absolute Cell Reference.
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2.4	 SWITCHING BETWEEN DIFFERENT REFERENCE TYPES:
To switch from a relative reference to absolute and vice versa, you can either type or delete the $ sign manually, or 
use the F4 shortcut:

a.	 Double-click the cell that contains the formula.

b.	 Select the reference you want to change.

c.	 Press F4 to toggle between the four reference types. Repeatedly hitting the F4 key switches the references in 
this order:

A1 > $A$1 > A$1 > $A1

2.5	EXTERNAL REFERENCE IN EXCEL:
An external reference in Excel allows you to refer to cells in other 
worksheets or workbooks. This can be extremely useful when you 
need to use data from multiple sources in your calculations or 

analysis. 
External Referencing can  be of two kinds.

1.	 Referring to a cell in another worksheet of the same workbook
1.	 Referring to a cell in another worksheet of another workbook

1.	 Creating An External Cell Reference: To Worksheet Of The Same Workbook
	 Syntax :       =SheetName!CellAddress

Where SheetName is the name of the worksheet where the cell is located and CellAddress is the address of the cell 
you want to reference.
Simple practice example:
Assume that we have two worksheets in the same workbook – Sheet1 and Sheet2. There are a list of numbers in 
cells A1:A5, and we want to show the sum these numbers in A1 cell ofSheet2.
To achieve this – Click A1 cell in Sheet2 use external cell reference in the sum formula to reference the numbers in 
Sheet1. Finally press the enter key to get the total.
		  =SUM(Sheet2!A1:A5)
Notice the use of ! symbol after the sheetname

1.	 Creating An External Cell Reference: To Worksheet Of another Workbook
External Cell Referencing in Excel allows to link data from one workbook to another, making it easier to consoli-
date and analyse information from multiple sources.
Syntax :   =[workbookName]SheetName!CellAddress
Where workbookName is the name of the Excel file, SheetName is the name of the sheet in this workbook, and 
CellAddress is the address of the cell you want to reference.

Example:- Type this formula , to reference cell A1 in a sheet named ‘QuarterlyReport’, in a workbook named 
SalesData.xlsx
	 =[SalesData.xlsx]QuarterlyReport!A1
Notice the use of ! symbol after the sheetname and the square brackets enclosing the workbook name
By using external cell references across different workbooks, you can easily access data from various sources and 
create dynamic reports that automatically update when source data changes.
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DO IT YOURSELF
DIY-Activity 2.1 : Prepare the T- Shirt Sales report excel sheet 
with daily total, product wise total and weekly total

a)	 Click cell H4 and type =sum(B4:G4) to find total number of 
Extra small T- Shirts.

b)	 Click H4 cell - Using the fill handle copy the formula to cells 
H5 to H8.

c)	 Click cell B9 and type

=sum(B4:B8)…to find total sales for Monday

d)	 Copy this formula to the cells C9 to G9 to find total sales for the other days of the week.

e)	 Also copy the formula to the cell H9 to find the Weekly Total sales for all the T-Shirts.

DIY Activity 2.2 : Prepare the following worksheet

1.	 Use absolute referencing to calculate Sales Tax.

2.	 Line total is to be recalculated as Unit Price * Quantity + 
Sales Tax

Solution:

Step 1: Type the data from cell A2 to D13. 

Step 2: Click the cell E5 and type “=C5*$F$3/100” to calculate 
Sales Tax for the Item - 10.5 Extra Thick Dinner Plates. 

Step 3: Copy this formula from cell E5 to cells E13.

Step 4: Click cell F5 and type the formula =C5*D5+E5 to calculate the Line total for 10.5” Extra Thick Dinner 
Plates

Step 5: To calculate the total cost click cell F14 and type =sum(F5:F13) 

Step 6: Format the Table

DIY Activity 2.3 : Prepare the following worksheet

a)	 Calculate total using auto sum–Click cell F10 and click the ∑Auto 
Sum tool from the Home tab.

b)	 Calculate Tax using the tax percentage saved in sheet 2 ( cell F3)

Click in cell F11 and type the formula - =F10*’Sheet 2’!F3

c)	 Calculate the grand total as =F10+F11

DIY Activity 2.4 :

Fill the content of cell E4 using the grand total, created 
in Activity 2.3

-	 Type the formula - =’Sheet 3’!F12	 in cell E4 of 
Sheet 4.
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ANSWER THE FOLLOWING :

1.	 If in D3 you have “=A1”, What cell does D3 refer to?

	 a.	 D3		  c. A1

	 b.	 D1		  d. A3

2.	 Getting data from a diferent cell is called …

	 a.	 Accessing	 b. Referencing

	 c. Updating		 d. Functioning

3.	 Which of the following is an absolute cell reference?

	 a.	 !A!1		  b. $A$1

	 c. #a#1		  d. A1

4.	 In Absolute Referencing, the relative position of rows and columns changes when you copy a formula.  
( TRUE OR FALSE? )

5.	 To use the sheet reference, which address is appropriate out of the following options?

	 a. D4! Sheet1	 b. Sheet1! D4	         c. Sheet! D4

6.	 Which of the following is relative reference?

	 a. $D6		  b. A3		          c. A$1

7.	 You can switch between references by pressing the

	 a. F1 key		  b. F2 key	          c. F3 key		 d. F4 key

8.	 The fastest way to go to a particular cell of a worksheet is to type the cell address in the

	 a. Name box	 b. Formula bar	 	 c. Zoom box	 d. Sheet tab

9.	 The default cell reference to another Excel file is

	 a. Relative reference		 b. Absolute reference		  c. Mixed cell reference

Teacher’s Signature
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Arguments are the values that are enclosed 
within the parenthesis of a function. 
Functions perform calculations on these 
arguments.

ESSENTIAL LEARNING SKILLS:
3.1	 Introduction

3.2	 IF( ) function in Excel

3.3	 Comparison Operators

3.4	 Countif Function

3.5	 SUMIF Function

3.6	 Averageif Function

3.1	  INTRODUCTION:
Conditional statements are the backbone of decision making in Excel. They allow users to create dynamic formulas that 
are capable of responding to data changes, thus making Excel a powerful tool for data analysis and decision making.

In this module we will  learn to use the most commonly used If() function, and  a few more advanced Conditional 
statements like COUNTIF(), SUMIF(), AVERAGEIF() that come in handy in certain situations.

3.2	  IF( ) FUNCTION IN EXCEL:
The If function/statement in Excel is a conditional statement that performs different operations based on logical 
tests. The IF function performs the logical test and return one value for a TRUE result, or another value for a FALSE 
result.

The IF function takes three arguments: logical_condition, 

value_if_true, and 

value_if_false:

SYNTAX :	 IF(logical condition, value_if_true, value_if_false) 

Example:-  if it’s raining, you take an umbrella; if not, you don’t.

You can write the Excel IF statement to represent this.

=if (Raining=”Yes”, “Take Umbrella”, “Don’t take Umbrella”) 

1.	 Here the logical condition is “Raining=”Yes”,  

2.	 the two actions are action 1:-  Take umbrella,   action 2:-  Don’t take umbrella.

3.	 The logical test, action 1, action 2 are the three arguments of the IF statement.

The if statement checks the logical test – is it raining?? And decides:-  to Take Umbrella OR Not to take Umbrella.

If function checks the result of logical condition and decides to return either value_if_true OR value_if_false

Note: We have used Comparison Operators while specifying the logical test.

CONDITIONAL STATEMENTS 
IN EXCELCH

AP
TE

R 3
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The If function in Excel often uses comparison operators to create the logical tests. These operators compare two or 
more values and the expression using them return TRUE or FALSE.

0.1	 Comparison Operators:

1)	 equal (=) : Checks if two values or strings are the same (A3=“apple”)

2)	 greater than (>) : Checks if one value is larger than the other (A4 > 8)

3)	 less than (<) : Checks if one value is smaller than the other (B3 < 10)

4)	 greater than or equal to (>=) : Checks if one value is larger or equal to another (E5>= 10)

5)	 less than or equal to (<=) : Checks if one value smaller than or equal to another (D3 <= 5)

6)	 not equal to (<>) : Checks if two values are not the same.(a2<>b2)

More than one logical test can be tested by nesting in the 
IF function or use the logical functions like AND and 
OR in conditional argument of the IF function.

In the given picture, we want to calculate bonus either as 
500 or 0 based on the Eligibility column. The If function 
for this =IF(B2=”Y”, 500, 0)

Translation: If the value in B2 is equal to “Y”, return 500 
Otherwise, return 0.

The same formula can be also be written as given below by changing the logic of the logical test. This formula also returns 
the same result:			  =IF(B2<>”Y”,0,500)

Translation: If the value in B2 is not equal to “Y”, return 0. Otherwise, return 500.

3.4	 COUNTIF FUNCTION:
Excel can do more than just simple math.

The COUNTIF function is one of the most useful function and you can use it to count the number of cells that 
contain a specific value in a range of values. It’s easier to use COUNTIF than to manually count yourself. The 
Countif function takes 2 arguments between the parenthesis.

SYNTAX : = COUNTIF(Range, Criteria)

Range: the range of cells to be evaluated

Criteria: the condition that the cells must meet to be counted – can be a number, expression, cell 
reference, text

Examples

1.	 Counting cells equal to a specific value:

=COUNTIF(A1:A10, 5)

Counts the number of cells in the range A1:A10 that are equal to 5.

2.	 Counting cells greater than a specific value:

=COUNTIF(A1:A10, “>5”)

Arguments are also 
called parameters
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Counts the number of cells in the range A1:A10 that are greater than 5.

3.	 Counting cells less than or equal to a specific value (can be used for greater than or equal to):

=COUNTIF(A1:A10, “<=5”)

Counts the number of cells in the range A1:A10 that are less than 5.

4.	 Counting cells that are not equal to a specific value:

=COUNTIF(A1:A10, “<>5”)

Counts the number of cells in the range A1:A10 that are not equal to 5.

5.	 Counting cells containing a specific text:

=COUNTIF(A1:A10, “Apple”)

Counts the number of cells in the range A1:A10 that contain the text “Apple”.

6.	 Counting cells based on a cell reference:

=COUNTIF(A1:A10, B1)

Counts the number of cells in the range A1:A10 that are equal to the value in cell B1.

The COUNTIF function is useful for analyzing data and summarizing specific information based on defined 
criteria

3.5 SUMIF FUNCTION:
The SUMIF function in Microsoft Excel allows you to calculate the sum of numbers in a range, based on a specific 
criterion. The Sumif function takes 3 arguments between the parenthesis.

SYNTAX : = SUMIF(Range, Criteria, Sum_Range) 

Parameters:

Range: The range of cells that you want to apply the criteria to.

Criteria: The condition that must be met for the cells in the range to be included in the sum. This can be

a number, expression, cell reference, or text string.

Sum_Range: The actual cells to sum. If omitted, Excel sums all the cells in the range parameter.

USAGE: 

1.	Sum cells equal to a specific value:

=SUMIF(A1:A10, 5)

Sums the values in the range A1:A10 that are equal to 5.

2.	Sum cells greater than a specific value (can be used with lesser than):

=SUMIF(A1:A10, “>5”)

Sums the values in the range A1:A10 that are greater than 5.

3.	Sum cells less than or equal to a specific value (can be used for greater than or equal to):

=SUMIF(A1:A10, “<=10”)

Sums the values in the range A1:A10 that are less than or equal to 10.
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4.	Sum cells not equal to a specific value:

=SUMIF(A1:A10, “<>5”)

Sums the values in the range A1:A10 that are not equal to 5.

5.	Sum cells containing specific text:

=SUMIF(A1:A10, “Apple”, B1:B10)

Sums the values in the range B1:B10 only when the corresponding cells in the range A1:A10 contain the text 
“Apple”.

6.	Sum cells based on a cell reference:

=SUMIF(A1:A10, B1, C1:C10)

Sums the values in the range C1:C10 only when the corresponding cells in the range A1:A10 match the value 
in cell B1.

The SUMIF function is powerful for Summing based on specified criteria, allowing for flexible data analysis and 
summarization.

3.5 AVERAGEIF FUNCTION:
The AVERAGEIF function in Excel calculates the average of the cells that meet a specified condition. 

SYNTAX:- =AVERAGEIF(Range, Criteria, Average Range) 

Parameters:

Range: The range of cells that you want to apply the criteria to.

Criteria: The condition that must be met for the cells in the range to be included in the average calculation. 
This can be a number, expression, cell reference, or text string.

Average_Range: The actual cells to average. If omitted, Excel averages the cells in the range parameter.

USAGE:

1.	Average cells equal to a specific value:

=AVERAGEIF(A1:A10, 5)

Averages the values in the range A1:A10 that are equal to 5.

2.	Average cells greater than a specific value (can be used for less than):

=AVERAGEIF(A1:A10, “>5”)

Averages the values in the range A1:A10 that are greater than 5.

3.	Average cells less than or equal to a specific value (can be used for greater than or equal to):

=AVERAGEIF(A1:A10, “<=10”)

Averages the values in the range A1:A10 that are less than or equal to 10.

4.	Average cells not equal to a specific value:

=AVERAGEIF(A1:A10, “<>5”)

Averages the values in the range A1:A10 that are not equal to 5.

5.	Average cells containing specific text:

=AVERAGEIF(A1:A10, “Apple”, B1:B10)

Averages the values in the range B1:B10 where the corresponding cells in the range A1:A10 contain the text 
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“Apple”.

6.	Average cells based on a cell reference:

=AVERAGEIF(A1:A10, B1, C1:C10)

Averages the values in the range C1:C10 where the corresponding cells in the range A1:A10 match the value in 
cell B1.

The AVERAGEIF function is useful for calculating the average of values that meet specific criteria, allowing for Targeted 
data analysis and summarization.

DO IT YOURSELF ACTIVITIES

A.	 Enter the age of a person in cell A2. Display if he/she is eligible to vote in cell B2 using IF function.

Step 1: Click on cell A2

Step 2: Enter the age of a person

Step 3: Click on cell B2

Step 4 : Enter =if(A2>=18,”Eligible to vote”, “Not 
Eligible”)

B.	 Enter ten number (positive and negative). Calculate and display the total of only positive numbers. 
Calculate and display the average of all negative numbers.

Step 1: Enter numbers 1 to 10 in cells B4 to B13

Step 2: Enter 10 numbers ( positive and negative numbers) in cells C4 to C13

Step 3: Click on cell C14 and enter

=SUMIF(C4..C13 0”)

Step 4: Click on cell C15 and enter =AVERAGEIF(C4..C13, “<0”)

C.	 Enter the points scored by 5 people and display the badge they are eligible to receive. A person gets a GREEN 
badge if the points scored are above 80 otherwise gets a BLUE badge. Also calculate the number of blue and 
green badges (use IF & COUNTIF)

Step 1: Click on B3 and enter Points

Step 2 : Click on C3 and enter Badge

Step 3: Enter the values as shown above in cells to B8

Step 4: Click on C4 and enter

=IF(B4>80,”GREEN”,”BLUE”)

Step 5: Click and drag till C8 to get the badge colours for other cells.

Step 6: Click on cell B10 and enter Blue Badges
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Step 7: Click on cell B11 and enter Green Badges

Step 8: Click on cell C10 and enter

=COUNTIF(C4:C8,”BLUE”)

Step 9: Click on cell C11 and enter =COUNTIF(C4:C8,”GREEN”)

D.	 Enter the age of 5 people. Calculate discount in train ticket of 8% for minors and senior citizens and 5% 
for the rest.

Step 1: Click on B2 and enter Age 

Step 2: Click on C2 and enter Amount 

Step 3: Click on D2 and enter Discount

Step 4: Enter the values 87,25,56,15,34 in cells B3 to B7

Step 5: Enter the values 580, 450, 200, 560 and 180 in cells C3 
to C7

Step 6: Click on cell D2 and type “ Discount”

Step 7: Click on cell D3 and enter =IF(B3>=18,8,5) and press 
Enter Key.

Step 8: Drag till cells D7 to get discount for other cells

Step 9: Click on cell E2 and enter Discount amount

Step10: Click on cell E3 and enter =C3*D3/100 and press Enter key

Step 11: Drag till cells E7 to get discount amount for other cells

E.	 Prepare a worksheet of 5 students to find the eligibility for rank. (use data given in the  picture below)

Step 1: Enter the row header as Student, sub1, sub2, sub3, sub4, sub5, Eligible for rank - in the 
cells from B2 to H2

Step 2: Enter student details in cells B3 to G7

Step 3: Click on H3 and type the formula below 

=IF( AND(C3>40,D3>40,E3>40,F3>40,G3>40), “Yes”, “No” )

Step 4: Click and drag fill handle from H3 till H7 to get eligibility for all other students.

AND operator is used in the If function to 
check multiple conditions.
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1.	 What is the =COUNTIF function in Excel used? 

a.	 Counts cells as specified

b.	 Counts blank cells in a range

c.	 Counts cells with numbers in a range

d.	 Returns values based on a TRUE or FALSE condition

2.	 The correct syntax of IF() Function. 

e.	 =IF (logical_test, TRUE([value_if_true]), FALSE([value_if_false]))

f.	 =IF (logical_test, [value_if_true], [value_if_false])

g.	 =IF (logical_test, {[value_if_true]}, {[value_if_false]})

h.	 =IF (logical_test: [value_if_true], [value_if_false])
3.	 Which of the following is the not equal to comparison operator used in an IF, COUNTIF or SUMIF 
function?

a.	 <=	

b.	 <>	

c.	 >=	

d.	 ><

4.	 Study the screenshot on the right. Which of the following functions, when inserted in the 
highlighted   cell (C2) above, will return the word “yes” ?

a. =IF(B2>50,”yes”)

b. =IF(C2=”yes”)

c. =IF(B2=C2, “yes”)

d. =IF(B2=50, “yes”)

5.	 Which function is used to add all numbers based on a specific criteria.

a.	 =SUMIF( )

b.	 Countif()

c.	 Averageif()

d.	 + operator
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6.	 If the cell B2 is 68, what will this IF function give you as a result?

=IF (B2>60, ‘’pass’’, ‘’fail’’)

a.	 Pass		  b.  fail			   c. 60			   d. none of these

7.	 Values enclosed within parenthesis of a function are called

a.	 Data		  b. Cell pointer		  c. Arguments		  d. Operators

8.	 The IF function can check more than one condition using

a.	 Nested If 				    c. Comparison operators

b.	 Countif()				    d. Sumif()

Teacher’s Signature
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ESSENTIAL LEARNING SKILLS
4.1	Introduction

4.2	Goal Seek

4.3	Scenario Manager

4.4	Pivot Tables Exercises

4.1 INTRODUCTION
Microsoft Excel is a powerful spreadsheet tool created by Microsoft. With many capabilities to handle a vast 
amount of data and perform various calculations, the software program has become the go-to for many  
business organizations and individuals. One of the features of Microsoft Excel that sets it apart from other programs 
is its What-If Analysis tools.

In this module, we will learn the What-If Analysis feature, its applications, and how it works in Microsoft Excel.

What is What-If Analysis in Excel?

What-If Analysis is a feature in Microsoft Excel that provides a way for users to explore different scenarios by 
changing variables in a formula. There are three main types of What-If Analysis in Excel:

•	 Goal Seek
•	 Scenario Manager
•	 Data Tables

(Only Goal Seek and Scenario Manager are discussed in this module)

4.2 GOAL SEEK
Goal Seek is Excel’s built-in What-If Analysis tool that shows how one value in a formula impacts another. More 
precisely, it determines what value you should enter in an input cell to get the desired result in a formula cell.
The best thing about Excel Goal Seek is that it performs all calculations behind the scenes, and you are only asked 
to specify these three parameters:

•	 Formula cell
•	 Target/desired value
•	 The cell to change in order to achieve the target

Goal Seek can tell you what score you must achieve for your last exam to receive an overall passing score of 70% 
(example 1). Or, how many votes you need to get in order to win the election (example 2).
On the whole, whenever you want a formula to return a specific result but are not sure what input value within the 
formula to adjust to get that result, stop guessing and use the Excel Goal Seek function!

Example 1:	 Determine the exam passing score

Problem: At the end of the course, a student takes 3 exams. The 
passing score is 70%. All the exams have the same weight, so the 
overall score is calculated by averaging the 3 scores. The student 
has already taken 2 out of 3 exams. The question is: What score 

WHAT…IF ANALYSIS 
IN EXCELCH

AP
TE

R 4



27

does the student need to get for the third exam to pass the entire course? 

Solution: Let’s do Goal Seek to determine the minimum score on exam 3:

•	 Set cell - the formula that averages the scores of the 3 exams (B5).

•	 To value - the passing score (70%).

•	 By changing cell - the 3rd exam score (B4).

Result: In order get the desired overall score, the student must achieve a minimum of 67% on the last exam:

Example 2:	 Elections- Number of votes

Problem: You are running for some elected position where a 
two-thirds majority (66.67% of votes) is required to win the 
election. Assuming there are 200 total voting members, how 
many votes do you have to secure?

Currently, you have 98 votes, which is quite good but not 
sufficient because it only makes 49% of the total voters:

 Solution: Use Goal Seek to find out the minimum number of “Yes” votes you 
need to get:

•	 Set cell - the formula that calculates the percentage of the 
current “Yes” votes (C2).

•	 To value - the required percentage of “Yes” votes (66.67%).

•	 By changing cell - the number of “Yes” votes (B2).

Result: What-If analysis with Goal Seek shows that to achieve the two-thirds mark or 66.67%, you need 133 “Yes” 
votes:
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4.3 SCENARIO MANAGER
Another what if analysis tool is the Scenario Manager. This option is somewhat more 
advanced than Goal Seek in that it allows the adjustment of multiple variables at the 
same time. Scenario Manager is a digital tool that allows a user to create, analyse and 
compare data results in different business situations. You can store multiple versions of 
data within the same cell, then change them depending on a scenario’s goal.

Some noticeable differences between Goal Seek and Scenario Manager are listed below:

·	 The Scenario Manager allows the creation of an unlimited number of possible scenarios by changing up 
to 32 variables at a time.

·	 Each scenario can be saved for comparative purposes.

·	 Scenarios may be named and edited, and a brief description provided.

·	 Only constant values should be changed within the Scenario Manager — cells with formulas should not 
be manually adjusted.

Example: To illustrate how Scenario Manager works, imagine that a bank is offering 
an interest rate of 9% per annum on personal loans with 24 months to repay, and 
that you would like to borrow $40,000. 

Using this  information, the bank calculates the amount borrowed plus interest 
over the loan period will be $47,200, as shown in cell B5. The amount to be paid 
each month is also calculated and shown in cell B6.

CREATING SCENARIOS: 

As a best practice, the original worksheet data should be saved as a scenario so that you can revert to it after all the experiments 
have been completed.

Step 1 - Click ‘What If Analysis’ from the Data tab and select Scenario Manager.

	 Step 2 - Click ‘Add’ from the Scenario Manager pop-up window.

Step 3 - Name this scenario “Original” and enter the cell references of all cells with constant values that you 
may consider changing in other scenarios 
(maximum 32 cells). Click OK.
Step 4 - For the “Original” scenario, do 
not a djust any values in the ‘Scenario Values’ 
window.
Step 5 – Click ‘Add to create your first 
experimental scenario.

2 3

4 5
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Creating experimental scenarios

When creating an experimental scenario, give the scenario a descriptive name in the ‘Add Scenario’ pop-up window. 
The changing cells will be the same as the ones referenced in your ‘Original’ scenario.
Even if you will not be adjusting all the values in those cells, it is highly recommended that they remain referenced in the 
‘changing cells’ field. You may place additional details about the experimental scenario in the ‘Comment’ field (

As illustrated above, our experimental scenario is given the name “36 months” and refers to cells B1 to B3 as 
changing cells. An additional comment indicates that this scenario is to determine the effect of borrowing
$40,000 over a 36-month period.

 In the ‘Scenario Values’ window, each changing cell is displayed as a field where we can manipulate the constant 
value so as to affect the outcome of the dependent cells — in our case, cells B5 and B6. As described in our 
scenario name and comments, we only adjust cell B3 by changing the value to 36. 

To add another scenario at this point, select ‘Add’. If not, click OK.
Adjust multiple variables

To experiment with adjusting multiple variables within one scenario, the steps are the same as above, with the exception 
that the desired changes would be made in the Scenario Values window.
For example, to get Excel to perform a what if analysis on borrowing
$50,000 over a 36-month period in the above situation at the same rate of interest, we would simply adjust the fields 
referencing those variables after creating a new scenario. Excel’s Scenario Manager can handle an unlimited number of 
scenarios created in this same way.
A list of created scenarios can be viewed by clicking OK from the Scenario Values window, or by selecting Scenario 
Manager from the What If Analysis dropdown menu.
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To see the outcome of each adjustment on the output cell(s), either double click on a scenario name, or highlight a 
name and click Show.

Scenario Summary
Scenarios that have been created may also be 
compared side by side with the creation of a Scenario 
summary worksheet, which is generated by selecting 
‘Summary’ from the Scenario Manager window.
Choosing the ‘Scenario summary’ option will 
create a new sheet within the workbook that displays 
each scenario in columnar format. Changing 
Cells are highlighted in gray, and Result Cells are 
displayed under Changing Cells.
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Note that if named ranges were created for Changing or Result Cells, range names will be displayed instead 
of cell references.

PIVOT TABLES IN EXCEL
Pivot tables in Excel is a powerful tool for summarizing, analyzing, and viewing large amounts of raw data in an easy-
to-read format. They are a popular user-friendly tool enabling technical/non-technical people alike to dive deeper 
into their data. Pivot table doesn’t change the raw data, but rather creates a new view of it. It is a simple tool to use, 
yet powerful.
At the most basic level, pivot tables enable you to create a data 
matrix in a row and column formats. You can apply filtering, 
sorting, aggregation, and summarization of your data in various 
ways. 

The major features of a PivotTable are as follows
•	 Creating a PivotTable is extremely simple and fast

•	 Instantly churning data by simple dragging of fields, sorting and filtering and different calculations on the 
data.

•	 Arriving at the suitable representation for your data as you gain insights into it.

•	 Creating reports on the fly.

•	 Producing multiple reports from the same PivotTable in a matter of seconds.

The sample data which we are going to use throughout this article is shown above and also available for practice.
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Before Creating a PivotTable Ensure that the first row in the data range has headers. You need headers because 
they will be the field names in your PivotTable.
To Create a Pivot Table

•	 Click the INSERT tab on the Ribbon.
•	 Click Tables > Click PivotTable

 The Create PivotTable dialog box appears. 
Select the following from the dialog box –

•	 In the Table/Range box, type the table name – 
SalesData_Range
•	 Under Choose where you want the PivotTable to 
be placed Click New Worksheet
•	 Click OK.

A new worksheet is created. The new worksheet contains an empty 
PivotTable on the left and a PivotTable Fields task pane on the 
right side of the worksheet. The PivotTable Fields task pane has four areas (Filters, Columns, Rows, and Values) 
where various field names can be placed to create the PivotTable. The task pane also includes a checklist area of the 
fields from which to choose from the data. 
As you can observe, the PivotTable Fields list appears on the right side of the worksheet, containing the header 

names of the columns in the data range  Drag a field name into the four areas to create a PivotTable. Alternatively, 
you can check the boxes for fields to be added to the table. Each of the areas operate in the following manner in a 
PivotTable:

1.	 Columns: The field is used to measure and compare data.
2.	 Rows: The field is for data you want to analyze.
3.	 Values: The field containing the values a table uses for summarizing and comparisons.
4.	 Filter (optional): A field used to sort table data. It is displayed in the upper left corner of a table 
and is an optional field for tables.

Further, on the Ribbon, two new tabs -  PivotTable Tools – ANALYZE and DESIGN appear.
Adding Fields to the PivotTable
To summarize the order amount according to 
salesperson

·	 Click on the field Salesperson in the 
PivotTable Fields pane and drag it to the 
ROWS area.

·	 Click the field Month in the PivotTable 
Fields list and drag that also to ROWS 
area.

·	 Click on Order Amount and drag it to 
VALUES area.

Your first PivotTable is ready as shown here.
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Observe that two columns appear in the PivotTable, one containing the Row Labels that you selected, i.e. 
Salesperson and Month and a second one from Values containing Sum of Order Amount . In addition to Sum 
of Order Amount month wise for each Salesperson, you will also get subtotals representing the total sales by that 
person. If you scroll down the worksheet, you will find the last row as Grand Total representing total sales.
Example : Create a pivot table to see region wise sales of each salesperson.
To summarize the order amount of salesperson for the months January, February, and March. 

•	 Click on the field Salesperson in the PivotTable Fields list and drag it to the ROWS area.
•	 Click the field Region in the PivotTable Fields list and drag that also to COLUMNS area.
•	 Click on Order Amount and drag it to ∑ VALUES area.

Voila your second PivotTable is ready.
NOTE : In a Pivot Table, the aggregate function is a mathematical operation applied to the values within a 
specific group or category. It summarizes and condenses the data, providing a consolidated view for better 
analysis. 
Common aggregate functions include SUM, AVG (average), COUNT, MIN (minimum), 
and MAX (maximum). The choice of the aggregate function depends on the type of data and the analysis goals.
To change the aggregate mathematical function, click the numeric field in the Values box of the Pivot Fields dialog 
box and click Value Fields Settings-> Click Summarize Value fields by and choose the type of calculations that 
you want to use to summarize data from the selected field and click OK.
Functions Mainly Used in a Pivot Table:

•	 Sum: Adds up the values in a selected field.
•	 Count: Counts the number of entries in a selected field.
•	 Average: Calculates the average of the values in a selected field.
•	 Min: Displays the minimum value in a selected field.
•	 Max: Displays the maximum value in a selected field.
•	 Product: Multiplies all the values in a selected field.
•	 Count Numbers: Counts only the numeric entries in a selected field.
•	 StdDev: Calculates the standard deviation of the values in a selected field.
•	 StdDevp: Calculates the standard deviation of the entire population of values in a selected field.
•	 Var: Calculates the variance of the values in a selected field.
•	 Varp: Calculates the variance of the entire population of values in a selected field.

These functions empower users to analyze and summarize data efficiently within a Pivot Table, providing valuable 
insights.
Rearrange fields in a variety of ways by dragging them into a new area of the Pivot Table Fields Box or clicking the 
option in the list of fields above the areas. Each action will affect the PivotTable. Move fields around into new areas 
until you have created a table giving you the best insight into your data.
The information above shows examples of what can be done with pivot tables, but keep in mind there are many more 
things you can do with pivot tables than what we have seen.
•	If you update your source data, refresh the pivot table to capture the latest updates made in your data. This is 
because pivot prevents automatic up-gradation once the source data has been updated.

Please use the following url 
to download the practice file

https://tinyurl.com/3c7n4wv8
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1.	 A __________ is an interactive Excel report that summarizes and analyzes large amounts of data.

2.	 The 	__________ is an area to position fields by which you want to filter the PivotTable report.

3.	 The __________ is an area to position fields that contain data that is summarized in a PivotTable.

4.	 		  is a what-if analysis tool that finds the input needed in one cell to arrive at the 
desired result in another cell.

5.	 Under which tab and in which function group will you find the option to insert a Pivot Table?

	 a. Under the Insert tab in the Tables group

	 b. Under the Formulas tab in the Data Analysis group

	 c. In the Data group in the Pivot Tables group

	 d. In the Data group in the Tables group

6.	 Which of the following is NOT a box in the PivotTable Fields List?

	 a. Column Labels	 b. Values 	 c. Filter		 d. Formula

7.	 To apply Goal Seek command your cell pointer must be in

	 a) The Changing cell whose value you need to find

	 b) The Result Cell where formula is entered

	 c) The cell where your targeted value is entered	

	 d) None of above

8.	 Which of the following is not What IF analysis tool in Excel?

	 a. Goal Seek	 b. Scenarios	 c. Data Tables	 d. Pivot Tables

9.	 What is a PivotTable?

	 a. tool used to summarize data

	 b. type of formula

	 c. type of chart

	 d. way to create macros

10.	What is the goal of “What-if ” analysis?

	 a. to calculate the maximum and minimum values in a range

	 b. to explore how changing input values affects calculated values

	 c. to create charts and graphs

	 d. to compare different versions of a workbook

11.	The four areas in this image are used to create a ____________.

Teacher’s Signature
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PROTECTION AND 
SECURITY IN EXCEL

ESSENTIAL LEARNING SKILLS:

5.1	 Protect Workbooks, Worksheets, and Cells

5.2	 Make a Workbook Read-Only

5.3	 Protect a Workbook’s Structure

5.4	 Protect a Worksheet from Editing

5.1	 PROTECT WORKBOOKS, WORKSHEETS, AND CELLS FROM 
EDITING
Excel files can be protected with passwords and other security options. Excel files are not secure by default. 
Security can be applied to Excel files at the workbook, sheet, or cell level, including the use of password security.

By protecting Excel workbooks, you can prevent other users from accidentally deleting important formulas or 
worksheets.

You can protect Excel workbooks at the file level or at the worksheet level. There are three levels of password 
protection in Excel: password protection to open a file, password protection to change data, or password protection 
for changing the file’s structure, such as adding, deleting, or hiding worksheets.

Protection in Microsoft Excel is password-based and happens at three different levels.

·	 Workbook: You have a few options for protecting a workbook. You can encrypt it with a password to limit 
who can even open it. You can make the file open as read-only by default so that people have to opt into editing 
it. And you protect the structure of a workbook so that anyone can open it, but they need a password to rearrange, 
rename, delete, or create new worksheets.

·	 Worksheet: You can protect the data on individual worksheets from being changed.

·	 Cell: You can also protect just specific cells on a worksheet from being changed. Technically this method involves 
protecting a worksheet and then allowing certain cells to be exempt from that protection.

NOTE: Both Workbook and Excel File are the same.

PROTECT AN ENTIRE WORKBOOK FROM EDITING

You have three choices when it comes to protecting an entire Excel workbook:

a.	 encrypt the workbook with a password,

b.	 make the workbook read-only

c.	 protect just the structure of a workbook.
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a.	 Encrypt a Workbook with a Password

For the best protection, you can encrypt the file with a password. Whenever someone 

tries to open the document, Excel prompts them for a password first.

To set it up, open your Excel file and

1. Click the File tab and Click Info

2. Click the “Protect Workbook” button

3. Choose “Encrypt with Password” from the dropdown menu.

4. In the Encrypt Document window that opens, type your password and then click “OK.”, Type your Password 

again and then click OK.

Note: Pay attention to the warning in this window. Excel does not provide any way to recover a forgotten password, 

so make sure you use one you’ll remember.

You’ll be returned to your Excel sheet. But, after you close it, the next time 

you open it, Excel will prompt you to enter the password.

b) To remove the password protection from the file,

1. Open it up (which of course requires you to provide the current password),

2. follow the same steps you used for assigning the password.

3. This time, make the password field blank an d then click “OK.”

5.2	 MAKE A WORKBOOK READ-ONLY

Making a workbook open as read-only is super simple. It doesn’t offer any 

real protection because anyone who opens the file can

enable editing, but it can serve as a suggestion to be careful about editing the 

file.

To set it up, open your Excel file and head to the File menu. You’ll see the 

“Info” category by default. Click the “Protect Workbook” button and then 

choose “Encrypt with Password” from the dropdown menu.
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Now, whenever anyone (including you) 

opens the  file, they get a warning stating 

that the file’s author would prefer they 

open it as read-only unless they need to 

make changes.

To remove the read-only setting, head back to the File menu, click the “Protect Workbook” button again, and 

toggle the “Always Open Read-Only” setting off.

5.3	 PROTECT A WORKBOOK’S STRUCTURE

The final way you can add protection at the workbook level is by protecting the workbook’s structure. This type of 

protection prevents people who don’t have the password from making changes at the workbook level, which means 

they won’t be able to add, remove, rename, or move worksheets.

To set it up, open your Excel file and head to the File menu. You’ll see the “Info” category by default. Click the 

“Protect Workbook” button and then choose “Encrypt with Password” from the dropdown menu. Type your 

password and click OK., Confirm your password and click OK.

Anyone can still open the document (assuming you didn’t also encrypt the workbook with a 

password), but	they won’t have access to the structural commands.

If someone knows the password, they can get access to those commands by switching over 

to the “Review” tab and clicking the “Protect Workbook” button.

They can then enter the password.

And the structural commands become 

available. This action removes the 

workbook structure protection from the document. To restore it, 

you must go back to the file menu and protect the workbook again.
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5.4	 PROTECT A WORKSHEET FROM EDITING

Protecting your worksheet means that no one can edit, reformat, or delete the content.

You can also protect individual worksheets from editing. When you protect a worksheet, Excel locks all of the cells 

from editing.

Click on the “Review” tab on the main Excel ribbon and Click “Protect Sheet”.

Enter the password you would like to use to unlock the sheet in the future.

Select the permissions you would like users to have for the worksheet after it is locked. 

For example, you might want to allow people to format, but not delete, 

rows and columns.

Click “OK” when you’re done selecting permissions.

Re-enter the password you made to confirm that you remember it and then click 

“OK.”

If you need to remove that protection, head to the “Review” tab and click the 

“Unprotect Sheet” button.

Type your password and then click “OK.”

Your sheet is now unprotected. Note that the protection is entirely removed and that you’ll need to protect the 

sheet again if you want.

a. Protect Specific Cells From Editing

Sometimes, you may only want to protect specific cells from editing in Microsoft Excel. For example, you might 
have an important formula or instructions that you want to keep safe. Whatever the reason, you can easily lock 
only certain cells in Microsoft Excel.

Start by selecting the cells you do not want to be locked. 
It might seem counterintuitive, but that’s how it is.

Now, right-click on the selected cells and choose the 
“Format Cells” command. In the Format Cells window, 
switch to the “Protection” tab.

Untick the “Locked” checkbox and click “OK”.
Now that you’ve selected the cells for which you want to allow editing, you can lock the rest of the worksheet by 
following the instructions in the previous section.

Note that you can lock a worksheet first and then select the cells you want to unlock, but Excel can be a little flaky 
about that. This method of selecting the cells you want to stay unlocked and then locking the sheet works better.
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PROS AND CONS OF PROTECT SHEET IN EXCEL

Pros
1.	 A protected Excel sheet with a password is disables sensitive information from unwanted changes done 

by unauthorized entities.

2.	 Excel worksheet cell actions are access controlled. It means they can be configured to be available for some 
users and not others.

Cons 

The password of the protected sheet is case-sensitive and is non-recoverable.

1.What is the purpose of Protecting sheet with a password?

To prevent users from accidentally or purposely making any modifications to the cells, worksheets, or the structure 
of the workbook, we can Protect the cells, worksheets, or workbook, respectively, by locking them with or without 
a password in the Excel worksheet.

2.	 What are the different methods to Protect Sheets in Excel?

There are three protection categories, as shown in the image below.

•	 Protect Sheet – It protects a particular worksheet from unwanted changes made by users by limiting their 
editing chances. If we want to protect multiple worksheets at a time, it is not possible. However, we can go to the 
necessary worksheets, one at a time, and protect sheets.

•	 Protect Workbook – It protects the entire workbook, i.e., Excel files worksheets. Here, users cannot make 
structural changes like adding, moving, or deleting worksheets.

•	 Allow Edit Ranges – It helps users to edit some cell ranges that are not password protected.
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1.	In order for the Lock or Unlock Cells function to work, which option should be enabled?

	 a. 	 The Protect Workbook function needs to be enabled.

	 b. 	 No functions need to be enabled other than the lock or unlock cells options.

	 c.	 The worksheet must be saved before the cells will become locked or unlocked.

	 d. 	 The Protect Worksheet function needs to be enabled.

2. What is the only way of removing password encryption on an Excel file?

	 a. 	 Resaving the workbook as a new document or making a copy of it.

	 b. 	 Opening the workbook as Read Only and resaving it without a password.

	 c. 	 Opening the workbook in Protected View and resaving it without a password.

	 d. 	 Entering the password to open the Workbook and then deleting the password created in the  

		  Permissions – Encrypt with Password box.

3. To protect a worksheet, you can choose Protection and the Protect Sheet from the ….. Tab

	 a. 	 Home                 b. 	 Data           c. 	 Review                       d. 	 Tools

4.	What is the main advantage of selecting the Mark as Final option?

	 a.	 It ensures that the workbook is free of errors.

	 b.	 It discourages other users from editing the workbook.

	 c.	 It prevents other users from editing the workbook.

	 d.	 It prevents other users from viewing the workbook.
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